Un objet Z-Wave est mal reconnu. Comment faire ?

Il arrive que certains matériels ne soient pas bien reconnus dans openHAB.
Ce tutoriel vous donne quelques astuces et la démarche pour corriger cela avec cet exemple sur un type Z-Wave.

Bonne lecture !

 

Un objet Z-Wave est mal reconnu, comment corriger le problème ?

 

 

Prérequis

. votre installation openHAB a déjà été faite
. Le connecteur (binding) Zwave a été installé

 


 

Ces jours-ci j'avais un objet Z-Wave à installer.
Il s'agit du FIBARO FGWP102

 

 

Comme d'habitude, la première chose à faire est de vérifier que cet objet est référencé dans openHAB.

 

 

1. Comment savoir si c'est un objet déjà référencé dans openHAB ?

 

Aller dans : PaperUI

Puis : Configuration

Puis : Bindings

Puis sélectionner le Z-Wave binding et là, la liste des objets référencés s'affiche (il y en a beaucoup !!!)

Je recherche ma référence :

 

 

 

Et il me trouve 2 configurations.

Donc normalement mon objet est bien référencé dans openHAB.

Nous allons donc "scanner" les objets Z-Wave pour qu'il puisse le trouver et l'ajouter à mes Things.

On pourrait penser qu'il faut à présent "brancher" son objet, dans mon cas le mettre sur une prise de courant.

Mais je rappelle ici que par défaut que cela ne sert à rien "d'actionner" son objet car le référencement est fait par la configuration du dongle Z-Wave.

Donc je vais rechercher (scanner).

Aller dans Things

Cliquer sur l'icône de scan situé au dessus (à côté de l'icône de rafraichissement de la page) :

 

Choisir de scanner un objet de type Z-Wave :

 

 

Il me trouve ceci :

 

 

 

Zut il me trouve pas directement mon object Z-Wave…
Je ne vois pas ma référence.

 

2. Unknown device

 

La solution en ce cas est de supprimer votre objet de votre dongle USB Z-Wave (Exclusion) et de le rajouter ensuite (Inclusion).

Avant tout je supprime le Things qu'il m'a trouvé et qui est mis en unknown… via la petite poubelle à droite.

(regardez vos notices d'exclusion d'objet pour cela)

Attention après cette manipulation certains objets risques de "bagotter" : de perdre leur connexion etc…

Pour résoudre ça faite une désinstallation du binding Z-Wave (vous ne risquez rien ne vous inquietez pas !!!)

Une fois fait, réinstallez le. Les connexions vont se refaire. Faite une tentative de scan dans le inbox… cette fois il ne trouve même plus mon objet qui était en unknown tout à l'heure…

Donc il a bien été exclu…

Bon maintenant on va purger le cache d'openHAB.

Pour cela on va dans la console et on stop openHAB :

 

sudo systemctl stop openhab2.service

 

 

 

Ensuite on purge le cache :

sudo openhab-cli clean-cache

Il va vous dire qu'au prochain lancement cela va prendre un peu plus de temps. Ok.

Et on redemarre openHAB.

 

sudo systemctl start openhab2.service

 

Comme dit précèdement cela va prendre un peu de temps. Donc soyez un peu patient : comme le cache a été purgé il doit reconstruire ses objets.

Là on va dans le inbox et ….

 

Il l'a trouvé !!!

 

Important

Cette méthode résoud très souvent le problème d'intégration d'un objet Z-WAve mal reconnu et pourtant listé dans openHAB.
Cependant si malgré cette manipulation openHAB persiste à retrouver votre object comme un "Unknown Device" il se peut qu'il faille laisse quelques heures pour que l'identification complète du produit puisse se faire.
Sur plusieurs appareils Z-Wave cela m'est arrivé.
Ainsi après votre manipulation, laissez une nuit openHAB tourner. Au matin vous verrez que votre appareil aura été identifé !

 

A bientôt dans un prochain tutoriel !

 

Annexe

Pour ceux qui ont un problème avec les LEDS de couleurs qui ne fonctionnent pas, il faut relire la notice du produit :

Le FIBARO Prise de courant a un MENU qui comporte plusieurs positions qui sont indiqués par le choix de la couleur de la LED.

Ainsi pour entrer dans le menu presser le bouton et le maintenir pendant 2s mini. Pendant que le bouton est pressé, la LED va changer de couleur dans l'ordre de séquence suivante :

BLANC– activation/désactivation de la LED de couleur d'indication de puissance consommée
VERT – réinitialisation de l'énergie consommée mémorisée
VIOLET – initialise le test réseau Z-Wave
JAUNE – réinitialise la prise d'après la configuration d'usine

Relâcher le bouton pour choisir la fonction désirée et confirmer votre choix par un clic sur le bouton.

 

 

 

Commentaires   
+1 # openHAB France - DomotiqueOCC CBD 04-09-2019 20:40
Hello there! This blog post could not be
written much better! Reading through this article reminds me of my
previous roommate! He always kept talking about this.
I most certainly will forward this post to him. Pretty sure he'll have
a good read. Many thanks for sharing!
Répondre | Répondre en citant | Citer
0 # Thanks !Editor 05-09-2019 01:33
Thank you for your words of encouragement ! Will try to continue with many tutorials !
openHAB is a great software !
Répondre | Répondre en citant | Citer
0 # openHAB France - DomotiqueInsta Keto Diets 28-10-2019 21:38
This is the right webpage for anybody who wishes to understand this topic.
You understand a whole lot its almost hard to argue with you
(not that I actually would want to?HaHa).

You definitely put a fresh spin on a topic
that has been written about for decades. Excellent stuff, just wonderful!
Répondre | Répondre en citant | Citer
Ajouter un Commentaire